Я получаю эту ошибку при запуске приложения. Вот подробности моей заявки.

Angular CLI: 7.3.3 
Node: 10.15.1 
Angular: 7.2.7 
@angular-devkit/architect -0.13.3 
@angular-devkit/build-angular- 0.800.1 
@angular-devkit/build-optimizer - 0.800.1 
@angular-devkit/build-webpack - 0.800.1 
@angular-devkit/core -7.3.3 
@angular-devkit/schematics -7.3.3 
@angular/cli -7.3.3 
@ngtools/webpack -8.0.1 
@schematics/angular -7.3.3 
@schematics/update 0.13.3 
rxjs 6.3.3 
typescript 3.2.4 
webpack 4.30.0

Я уже пробовал очистить кеш.

Ekta Gandhi

Ответов: 18

Ответы (18)

У меня была такая же проблема, но я решил ее благодаря комментарию Экта Ганди:

Наконец-то я нашел решение.

1) Сначала удалите все изменения в файле package.json, дав простую команду git checkout package.json.

2) Затем после внесения изменений в package.json в @ angular-devkit / build-angular- ~ 0.800.1 (Добавить хвост вместо шапки)

3) Затем выполните команду rm -rf node_modules /

4) Затем очистите улов, дав команду npm clean cache -f

5) И, наконец, запустите команду npm install. У меня это работает.

.... Вместе с модификацией, предложенной Dimuthu

Сделал это в @ angular-devkit / build-angular ":" 0.13.4 ", и это сработало.

У меня была эта проблема, вот как я ее решил. Проблема в основном в том, что ваша версия Angular не поддерживает вашу версию Node.js для сборки. Итак, лучшее решение - обновить ваш Node.js до самой последней стабильной версии.

Для чистого обновления Node.js я советую использовать n. если вы используете Mac.

npm install -g n
npm cache clean -f
sudo n stable
npm update -g

а теперь проверьте, что вы обновились:

node -v
npm -v

Подробности по этой ссылке: здесь

Здесь все сосредоточены на понижении версии @ angular-devkit / build-angular до версии @angular 7.x для совместимости, но они должны обновить @ angular / cli до версии angular 8.

• 100001 несовместимая версия при попытке доступа к библиотекам angular.

Downgrading @angular-devkit/build-angular just causes more incompatibilities.

npm i --global @angular/cli@latest

исправит проблему без нарушения чего-либо в другом месте.

Вы можете просто проверить свой код, а затем

#sudo su 
rm -rf package-lock.json node_modules
sudo npm i --save 

Если вы перейдете на угловой 8 или 9, это поможет

ng update @angular/cli

На самом деле у меня сработало обновление приложения и его зависимостей с помощью:

ng update @angular/cli @angular/core

Angular документация

Ни один из приведенных выше ответов не работает для меня.

Моей первоначальной целью было исправить иногда ПОСТОЯННУЮ компиляцию моего проекта с помощью VSCode.

Я пробовал много-много способов, но НИЧЕГО не работало - проект просто НЕ КОМПИЛИРУЕТСЯ!

Finally I found out what the problem here is:

Я клонировал проект из репозитория моей компании, и весь код оттуда ДОЛЖЕН соответствовать версиям зависимостей при кодировании существующей части проекта.

В конце концов, я удалил ранее клонированный проект СНОВА (довольно много раз)и клонировал СНОВА (тоже несколько раз), а НИЧЕГО НЕ ДЕЛАЛ, НО ЗАБЫЛ "npm install", и все заработало.

Урок, который я усвоил здесь, таков:

Иногда вы усугубляете ситуацию, когда пытаетесь исправить некоторые проблемы (у меня была CONSTANT COMPILING моего проекта).

Но это не значит, что мы не можем пытаться исправить проблемы. Мы можем. Но когда все становится беспорядком, лучше использовать исходный код.

К счастью, ПОСТОЯННАЯ компиляция моего проекта происходит только время от времени, а не постоянно. Это не исправлено, но я должен смириться, иначе мой проект даже не скомпилируется.

работает переустановить @ angular-devkit /build-angular@0.13.4

npm install @angular-devkit/build-angular@0.13.4 --save-dev

Следующие сработали для меня

npm uninstall @angular-devkit/build-angular
npm install @angular-devkit/build-angular@0.13.0

Ваш @ angular-devkit несовместим с версией @ angular / cli, поэтому просто установите более старую версию, например:

npm install @angular-devkit/build-angular@0.13.8 @angular-devkit/build-ng-packagr@0.13.8

Я также столкнулся с этой проблемой и часами изо всех сил пытался ее решить, я пробовал все вышеперечисленные варианты, но ничто не решило мою проблему. Эта проблема возникает из-за несовпадения версий angular / cli и angular-devkit, поэтому я сделал следующее:

  1. Версия файлов, измененная вручную:

    @ angular-devkit / build-angular ":" ^ 0.13.9 ",

    @ angular / cli ":" ~ 7.0.3 ", // Это для Angular7, для Angular8: 0.803.23

  2. Удален package-lock.json

  3. Выполнено: установка npm

Это решило мою проблему.

Я также сталкивался с этой проблемой, и у меня, когда я делал больше обновлений, возникало больше проблем.

Что сработало для меня в конце концов, так это удалить angular cli и переустановить его, выполнив следующие действия:

npm uninstall -g @angular/cli
npm cache clean --force
npm install -g @angular/cli

это выручило меня источник: как удалить angular / cli

В вашем package.json измените конструктор devkit.

"@angular-devkit/build-angular": "^0.800.1",
От

до

"@angular-devkit/build-angular": "^0.10.0",

у меня работает.
удачи.

Та же проблема после попытки обновления до Ng8, которая не удалась из-за проблем с зависимостями.

удаление npm @ angular-devkit / build-angular

тогда я использовал,

npm install @ angular-devkit /build-angular@0.12.4

исправил ...

Все сосредоточены на понижении версии @ angular-devkit / build-angular до X или обновлении @ angular / cli до версии Y или последней.

Однако, пожалуйста, не вслепую предлагать X или Y или последнюю в качестве ответов.(Хотя обычно понижение версии devkit должно быть лучше, потому что обновление CLI - критическое изменение)

Выбор правильной версии всегда зависит от вашей версии Angular (angular-cli).

Angular CLI v8.3.19 -> 0.803.19
Angular CLI v8.3.17 -> 0.803.17
Angular CLI v7.3.8 -> 0.13.8
Angular CLI v6-lts -> 0.8.9

Для других конкретных версий посетите: https://github.com/angular/angular-cli/tags. Найдите свою версию CLI, и в некоторых тегах они упоминают соответствующие версии для пакетов @ angular-devkit / **.

Примечание. Если вы хотите обновить версию интерфейса командной строки, вам следует сначала подумать об обновлении до последней основной версии, а не просто переходить к следующей основной версии.

У вас несовместимые зависимости. Я решил эту проблему, изменив package.json из другого проекта angular, а затем после изменения этого packag.json вы измените только те версии зависимостей, которые у вас есть.

после изменения напишите:

-npm ссылка

-npm serve -o

то работает :)

   {
   "name": "angular-jwt-auth",
   "version": "0.0.0",
   "scripts": {
   "ng": "ng",
   "start": "ng serve",
   "build": "ng build",
   "test": "ng test",
   "lint": "ng lint",
   "e2e": "ng e2e"
   },
   "private": true,
   "dependencies": {
   "@angular/animations": "^7.1.4",
   "@angular/cdk": "^7.3.1",
   "@angular/common": "~7.1.0",
   "@angular/compiler": "~7.1.0",
   "@angular/core": "~7.1.0",
   "@angular/forms": "~7.1.0",
   "@angular/http": "^6.1.10",
   "@angular/material": "^7.3.1",
   "@angular/platform-browser": "~7.1.0",
   "@angular/platform-browser-dynamic": "~7.1.0",
   "@angular/router": "~7.1.0",
   "@ng-bootstrap/ng-bootstrap": "^4.2.0",
   "@types/jquery": "^3.3.29",
   "angular-6-datatable": "^0.8.0",
   "bootstrap": "^4.3.1",
   "chart.js": "^2.8.0",
   "core-js": "^2.5.4",
   "jquery": "^3.4.1",
   "rxjs": "~6.3.3",
   "zone.js": "~0.8.26"
    },
   "devDependencies": {
   "@angular-devkit/build-angular": "~0.11.0",
   "@angular/cli": "~7.1.0",
   "@angular/compiler-cli": "~7.1.0",
   "@angular/language-service": "~7.1.0",
   "@types/chart.js": "^2.7.53",
   "@types/jasmine": "^2.8.16",
   "@types/jasminewd2": "^2.0.6",
   "@types/node": "~8.9.4",
   "codelyzer": "~4.2.1",
   "jasmine-core": "~2.99.1",
   "jasmine-spec-reporter": "~4.2.1",
   "karma": "~3.1.1",
   "karma-chrome-launcher": "~2.2.0",
   "karma-coverage-istanbul-reporter": "~2.0.1",
   "karma-jasmine": "~1.1.2",
   "karma-jasmine-html-reporter": "^0.2.2",
   "protractor": "~5.4.0",
   "ts-node": "~7.0.0",
   "tslint": "~5.11.0",
   "typescript": "~3.1.6"
   }

Это случилось со мной, когда я установил Angular 8, есть некоторые несовместимости, которые я не мог решить. Мне пришлось перейти на более раннюю версию, потому что я спустился в кроличью нору, жонглируя каждой версией, пока не нашел ту, которая работает.

Во-первых, TypeScript устарел, при установке по умолчанию добавлена ​​ссылка на TypeScript 3.1.6, и для него требуется версия 3.4 или выше.

npm install typescript @ "> = 3.4 <3.5"

Во-вторых, использование devkit 0.800.1 или 0.800.1 всегда приводило к несовместимости. Я пробовал много комбинаций, но я еще не уверен, что они полностью совместимы, особенно потому, что я использую одну начальную загрузку немного старше, и я еще не могу выполнить обновление.

Наконец, я попытался перейти на более раннюю версию (зайдите в package.json и найдите devDependencies), пока один из них не сработает.

@ angular-devkit / build-angular ":" 0,13.4 "

Я уверен, что ваша проблема в версиях зависимостей, но я не могу сказать, какая именно. Попробуйте понизить версию.

На моей стороне был пакет

@ angular-devkit / build-angular

и

@ angular-devkit / build-ng-packagr

was not the same version, Updating build-ng-packagr to same version as build-angular fixed my problem.

2022 WebDevInsider