I am new in Android Studio. After setup, When I am trying to import an application I am getting that error So that gradle not able to build.

Error:Could not initialize class org.codehaus.groovy.runtime.InvokerHelper

I checked that my classpath setting for Java is fine. I am running Windows OS. Does anyone know the source of the error?

sm_

Ответов: 24

Ответы (24)

I faced this issue because of lower version of Jdk. Previously I installed Jdk 1.7 and Android Studio 1.5.1, I got this issue. If you install Android Studio 1.5.1 or above JDK 1.8 required

So Installing JDK 1.8 solved this issue.

I get this error when I open a new project with VS Code & Flutter. I solved the problem by editing the gradle.build and gradle-wrapper.properties files.

Edit android>build.gradle like this:

dependencies { classpath 'com.android.tools.build:gradle:3.5.0' classpath 'com.google.gms: google-services: 4.3.3' //add this line classpath "org.jetbrains.kotlin: kotlin-gradle-plugin: $ kotlin_version" }

Edit gradle-wrapper.properties

distributionUrl=https://services.gradle.org/distributions/gradle-6.3-all.zip

I also had the same problem and and it looks like this problem is due to the gradle version in the project directory

  • This is the version of my jdk:
openjdk version "15-ea" 2020-09-15
OpenJDK Runtime Environment (build 15-ea+32-Ubuntu-220.04)
OpenJDK 64-Bit Server VM (build 15-ea+32-Ubuntu-220.04, mixed mode, sharing)
  • Please check gradle whether it is installed. This is the version of my gradle:
------------------------------------------------------------
Gradle 6.8
------------------------------------------------------------

Build time:   2021-01-08 16:38:46 UTC
Revision:     b7e82460c5373e194fb478a998c4fcfe7da53a7e

Kotlin:       1.4.20
Groovy:       2.5.12
Ant:          Apache Ant(TM) version 1.10.9 compiled on September 27 2020
JVM:          15-ea (Private Build 15-ea+32-Ubuntu-220.04)
OS:           Linux 5.4.0-65-generic amd64
  • Then open the gradle-wrapper.properties file in your project folder, in the folder: project name/android/gradle/wrapper/gradle-wrapper.properties

  • Change the gradle version. Here I changed the gradle version to 6.5

The video version can be seen here: https://www.youtube.com/watch?v=mcclcscUpV0

First watch this and try reinstall - https://youtu.be/trHinrIm6DM

After if you get "Could not initialize class org.codehaus.groovy.runtime.InvokerHelper"

1.install Java SDK 14 and update env path.

2."[Your RN or Flutter Project Folder]\android\gradle\wrapper\gradle-wrapper.properties" this file edit as ...(upgrade gradle version)

#Fri Jun 23 08:50:38 CEST 2017
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-6.3-all.zip

3.run gradlew in cmd path "[Your RN or Flutter Project Folder]\android\"

4.it takes time.after if shows "BUILD SUCCESSFUL" you can "flutter run" in ur project folder

Yeah It's work 👍

Please make changes as per below to resolve this error.

Install Java SDK version: 14 or above.

JDK Download link: https://www.oracle.com/java/technologies/javase-jdk14-downloads.html

In gradle-wrapper.properties please use grade version 6.3 or above.

For e.g:distributionUrl=https\://services.gradle.org/distributions/gradle-6.3-all.zip

In my case problem was that my version of gradle was incompatible with jdk14, but despite in project structure dialog was selected 8jdk, it was necessarily to set jdk home for gradle separately in gradle.propperties

org.gradle.java.home=/Library/Java/JavaVirtualMachines/jdk1.8.0_251.jdk/Contents/Home

gradle-wrapper.properties please use grade version 6.3 or above

distributionUrl=https://services.gradle.org/distributions/gradle-6.3-all.zip

../android/gradle/wrapper/gradle-wrapper.properties

I'm using Pop OS 20.04 and I have Java versions 8, 11 and 14 installed on my notebook.

This error was happening to me when version 14 was standard.

When I switched to using version 11 as the default, the error no longer occurred.

sudo update-alternatives --config java

I face this issue when I was Building my Flutter Application. This error is due to the gradle version that you are using in your Android Project. Follow the below steps:

distributionUrl = https://services.gradle.org/distributions/gradle-6.3-all.zip

Now Save the File (Ctrl + S), Go to the console and run the command

flutter run

It will take some time, but the issue that you were facing will be solved.

In gradle-wrapper.properties file, updating the Gradle to 6.3 solved the problem on Mac OS Catalina

distributionUrl=https://services.gradle.org/distributions/gradle-6.3-bin.zip

I fixed it just by editing the gradle-wrapper.properties file.

You must go to the project folder, then /android/grandle/wrapper/gradle-wrapper.properties. In DistributionUrl, change to https \: //services.gradle.org/distributions/gradle-6.4.1-all.zip.

(Solution) I tried my first flutter app in android studio , i was getting same error " Could not initialize class org.codehaus.groovy.runtime.InvokerHelper"

open build.gradle and update dependencies

    classpath 'com.android.tools.build:gradle:4.0.1'
    classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"

or just hover over com.android.tools.build:grandle:(your-version)

I had the same issue when building the Flutter project, I edited this file gradle-wrapper.properties
location: android -> grade\wrapper -> gradle-wrapper.properties

from this to:

distributionUrl=https\://services.gradle.org/distributions/gradle-5.6.4-all.zip

to this:

distributionUrl=https\://services.gradle.org/distributions/gradle-6.7-all.zip

but was not solved, I did flutter doctor and found some error in the android toolchain. I open android studio and installed "Android SDK Command-line tools" in SDK manager. https://stackoverflow.com/a/69604498/13577765

and was solved.

Resolve It:

distributionUrl=https\://services.gradle.org/distributions/gradle-6.0.1-all.zip

and I changed it into:

distributionUrl=https\://services.gradle.org/distributions/gradle-7.0-all.zip

The problem in my case was in the discrepancy between the Gradle version installed globally and the one required by React Native. To fix it, I had to update the folder android/gradle/wrapper from the current 6.5 RN version from GH.

For me the solution was to upgrade the gradle version to 6.3 from the android project structure (java 14.0.1 is already installed on my pc).

If you are using jdk 16 downgrade to 14 and gradle-wrapper.properties use 6.3 don't forget to upgrade build gradle in build.gradle to 4+

When you upgrade to the latest version of the gradle in the gradle-wrapper.properties file i.e. distributionUrl=https\://services.gradle.org/distributions/gradle-6.6.1-bin.zip please do not forget to change the gradle version in the build.gradle file as well

wrapper {
    gradleVersion = '6.6.1'
}

So I also got the same error on my system when I Cloned a project from github. The project that i created on my system worked without any errors. So if you are also in similar situation this could help 1-Go to this path

project-name/android/gradle/wrapper/gradle-wrapper.properties

2-Replace everything inside with this

distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-6.3-all.zip
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists

What was helpful for me (MacBook):

  • first go to File -> Invalidate Caches / Restart -> Invalidate and Restart
  • then check the value of JAVA_HOME enviroment variable, by calling echo $JAVA_HOME (it should be equal to "/Applications/Android Studio.app/Contents/jre/jdk/Contents/Home")
  • if it is not, change its value by calling export JAVA_HOME="/Applications/Android Studio.app/Contents/jre/jdk/Contents/Home"
  1. This is because of the gradle version.

  2. Go to: gradle/wrapper/gradle-wrapper.properties.

  3. Change a version of the course by this:

distributionUrl=https\://services.gradle.org/distributions/gradle-6.3-all.zip

The console outputs:

Welcome to Gradle 6.3!

Here are the highlights of this release:
 - Java 14 support
 - Improved error messages for unexpected failures

For more details see https://docs.gradle.org/6.3/release-notes.html

Starting a Gradle Daemon (subsequent builds will be faster)
  1. Go to \android\gradle\wrapper\gradle-wrapper.properties.
  2. Update the installing distribution version (all.zip) of Gradle in distributionUrl. As an example for Gradle version 6.8:

distributionUrl=https://services.gradle.org/distributions/gradle-6.8-all.zip

It is not enough to change distributionUrl in gradle-wrapper.properties, you also need to change gradle version in your project structure.

  1. Go to gradle-wrapper.properties and change:

distributionUrl=https://services.gradle.org/distributions/gradle-6.8-all.zip

  1. Go to Android studio -> file -> project structure

Change gradle verison to 6.8 or whatever verison you selected that is compatible with your jdk.

When I tried "react-native run-android" I was receiving errors "Could not initialize class org.codehaus.groovy.runtime.InvokerHelper" + "Failed to install the app. Make sure you have the Android development environment set up"....

Solved it by updating the gradle in Android Studio. When I opened my project in Android Studio it showed a message asking to update Gradle, and I just clicked.

2022 WebDevInsider