Following warning is being thrown on npm install command -

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.2 (node_modules\rea
ct-scripts\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@
1.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}
)
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\ch
okidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@
1.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}
)

Предупреждение, по-видимому, приводит к тому, что наша работа Jenkins помечается как неудачная, поэтому мы просто пытаемся избавиться от того же самого.

Это я уже проверял https://stackoverflow.com/a/42938398/351903 Но, в отличие от упомянутого там, в моей настройке нет / node_modules / fserrors. Кроме того, мой package.json не содержит ошибок. Ниже мой package.json -

{
  "name": "mvc-panel",
  "version": "0.1.0",
  "private": true,
  "dependencies": {
    "bootstrap": "^3.3.7",
    "jquery": "^3.2.1",
    "material-ui": "^0.18.3",
    "qs": "^6.4.0",
    "react": "^15.5.4",
    "react-alert": "^2.1.2",
    "react-bootstrap-table": "^3.4.1",
    "react-dom": "^15.5.4",
    "react-loader": "^2.4.2",
    "react-router-dom": "^4.1.1",
    "react-tap-event-plugin": "^2.0.1",
    "serve": "^6.0.0"
  },
  "devDependencies": {
    "datatables.net": "^1.10.15",
    "jquery": "^3.2.1",
    "react-scripts": "^1.0.7"
  },
  "scripts": {
    "start": "react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test --env=jsdom",
    "eject": "react-scripts eject"
  }
}

Я вижу fsevents в package.json сценариев реакции (которые определены в devDependencies моего package.json) в node_modules \ response-scripts \ package.json -

{
  "_args": [
    [
      {
        "raw": "react-scripts@^1.0.7",
        "scope": null,
        "escapedName": "react-scripts",
        "name": "react-scripts",
        "rawSpec": "^1.0.7",
        "spec": ">=1.0.7 <2.0.0",
        "type": "range"
      },
      "D:\\Sandeepan\\Payu MVC\\backend codebase\\MVC2.0\\panel\\mvc-panel"
    ]
  ],
  "_from": "react-scripts@>=1.0.7 <2.0.0",
  "_id": "react-scripts@1.0.14",
  "_inCache": true,
  "_location": "/react-scripts",
  "_nodeVersion": "8.5.0",
  "_npmOperationalInternal": {
    "host": "s3://npm-registry-packages",
    "tmp": "tmp/react-scripts-1.0.14.tgz_1506471610836_0.5613740666303784"
  },
  "_npmUser": {
    "name": "timer",
    "email": "timer150@gmail.com"
  },
  "_npmVersion": "5.3.0",
  "_phantomChildren": {
    "asap": "2.0.6",
    "escape-string-regexp": "1.0.5",
    "graceful-fs": "4.1.11",
    "has-ansi": "2.0.0",
    "universalify": "0.1.1"
  },
  "_requested": {
    "raw": "react-scripts@^1.0.7",
    "scope": null,
    "escapedName": "react-scripts",
    "name": "react-scripts",
    "rawSpec": "^1.0.7",
    "spec": ">=1.0.7 <2.0.0",
    "type": "range"
  },
  "_requiredBy": [
    "#DEV:/"
  ],
  "_resolved": "https://registry.npmjs.org/react-scripts/-/react-scripts-1.0.14.tgz",
  "_shasum": "70fe76c9beb67b136b953e875bdfe4ad78d410d1",
  "_shrinkwrap": null,
  "_spec": "react-scripts@^1.0.7",
  "_where": "D:\\Sandeepan\\Payu MVC\\backend codebase\\MVC2.0\\panel\\mvc-panel",
  "bin": {
    "react-scripts": "./bin/react-scripts.js"
  },
  "bugs": {
    "url": "https://github.com/facebookincubator/create-react-app/issues"
  },
  "dependencies": {
    "autoprefixer": "7.1.2",
    "babel-core": "6.25.0",
    "babel-eslint": "7.2.3",
    "babel-jest": "20.0.3",
    "babel-loader": "7.1.1",
    "babel-preset-react-app": "^3.0.3",
    "babel-runtime": "6.26.0",
    "case-sensitive-paths-webpack-plugin": "2.1.1",
    "chalk": "1.1.3",
    "css-loader": "0.28.4",
    "dotenv": "4.0.0",
    "eslint": "4.4.1",
    "eslint-config-react-app": "^2.0.1",
    "eslint-loader": "1.9.0",
    "eslint-plugin-flowtype": "2.35.0",
    "eslint-plugin-import": "2.7.0",
    "eslint-plugin-jsx-a11y": "5.1.1",
    "eslint-plugin-react": "7.1.0",
    "extract-text-webpack-plugin": "3.0.0",
    "file-loader": "0.11.2",
    "fs-extra": "3.0.1",
    "fsevents": "1.1.2",
    "html-webpack-plugin": "2.29.0",
    "jest": "20.0.4",
    "object-assign": "4.1.1",
    "postcss-flexbugs-fixes": "3.2.0",
    "postcss-loader": "2.0.6",
    "promise": "8.0.1",
    "react-dev-utils": "^4.1.0",
    "style-loader": "0.18.2",
    "sw-precache-webpack-plugin": "0.11.4",
    "url-loader": "0.5.9",
    "webpack": "3.5.1",
    "webpack-dev-server": "2.8.2",
    "webpack-manifest-plugin": "1.2.1",
    "whatwg-fetch": "2.0.3"
  },
  "description": "Configuration and scripts for Create React App.",
  "devDependencies": {
    "react": "^15.5.4",
    "react-dom": "^15.5.4"
  },
  "directories": {},
  "dist": {
    "integrity": "sha512-+p0q2N2WW7L4WW6uObqN7fYwSQZ9fBI0StpMYl1Ukoz/lCbemf+yW6b8refyhTsGy62GAqxlpyEfVcTE3hJAxg==",
    "shasum": "70fe76c9beb67b136b953e875bdfe4ad78d410d1",
    "tarball": "https://registry.npmjs.org/react-scripts/-/react-scripts-1.0.14.tgz"
  },
  "engines": {
    "node": ">=6"
  },
  "files": [
    "bin",
    "config",
    "scripts",
    "template",
    "utils"
  ],
  "homepage": "https://github.com/facebookincubator/create-react-app#readme",
  "license": "MIT",
  "maintainers": [
    {
      "name": "timer",
      "email": "timer150@gmail.com"
    },
    {
      "name": "fb",
      "email": "opensource+npm@fb.com"
    },
    {
      "name": "gaearon",
      "email": "dan.abramov@gmail.com"
    }
  ],
  "name": "react-scripts",
  "optionalDependencies": {
    "fsevents": "1.1.2"
  },
  "readme": "ERROR: No README data found!",
  "repository": {
    "type": "git",
    "url": "git+https://github.com/facebookincubator/create-react-app.git"
  },
  "version": "1.0.14"
}

Обновить

Я попытался запустить команду установки npm и получить статус выхода предыдущей команды. Он показал 0, что означает успех, несмотря на предупреждения. Так что не похоже, что работа Дженкинса должна застрять из-за этого. Однако мы все еще пытаемся найти способ избавиться от этого предупреждения, поскольку оно не имеет отношения к нашей ОС.

Ответы (21)

fsevents по-разному обрабатывается в Mac и других Linux-системах. Система Linux игнорирует fsevents, тогда как Mac устанавливает его. Поскольку в приведенном выше сообщении об ошибке указано, что fsevents является необязательным и пропускается в процессе установки.

Вы можете запустить команду npm install --no-optional в системе Linux, чтобы избежать вышеуказанного предупреждения.

Дополнительная информация

https://github.com/npm/npm/issues/14185

https://github.com/npm/npm/issues/5095

npm i -f

Я хотел бы повторно опубликовать некоторые комментарии из этой ветки, где вы можете прочитать о проблеме и проблема была решена.

Это как раз проблема Angular. Текущий package.json требует fsevent как не optionalDependencies, а devDependencies. Это может быть проблемой для пользователей, отличных от OSX.

Иногда

Даже если вы удалите его из package.json npm, у меня все равно не получится, потому что другой модуль имеет его как одноранговый деп.

Так

если npm-shrinkwrap.json все еще существует, удалите его или попробуйте npm i -f

Я обнаружил ту же проблему и попробовал все решения, упомянутые выше и в github. Некоторые из них работают только в локальном репозитории, когда я отправляю свой PR в удаленные репозитории с помощью travic-CI или Pipelines, я возвращаю ту же ошибку. Наконец, я исправил это, используя команду npm ниже.

исправление аудита npm --force

У меня такая же ошибка. В моем случае я использовал подключенный диск для редактирования кода со второго компьютера, на котором работала Linux. Не уверен, почему gulp-watch полагается на совместимость с операционной системой перед установкой (я бы предположил, что это связано с целями безопасности). По сути, ошибка проверяется на соответствие вашей операционной системе и операционной системе, вызывающей модуль узла, в моем случае две операционные системы не были одинаковыми, поэтому это вызвало ошибку. Что, судя по твоей ошибке, совпадает с моей.

Ошибка

Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

Как я это исправил?

Я напрямую зашел в Linux и запустил

npm install --save-dev 

Затем вернулся в свою среду кодирования, и после этого все было в порядке.

Надеюсь, что это поможет!

У меня была эта ошибка, система Linux (Ubuntu), и это могло произойти при запуске:

установка npm

1) Если проект отсутствует на вашем локальном диске / компьютере, скопируйте его на свой компьютер и попробуйте еще раз. Таким образом, вы получаете разрешение на доступ к папке (просто убедитесь, что у вас есть разрешение на доступ).

2) Если вы все еще получаете предупреждения или ошибки, запустите:

исправление аудита npm

Это устранит уязвимости в ваших зависимостях и может помочь вам исправить уязвимость, предоставив простые в использовании команды npm и рекомендации по дальнейшему устранению неполадок.

Надеюсь, это поможет!

Вместо использования - no-optional каждый раз, мы можем просто добавить его в конфигурацию npm или yarn.

Для Yarn есть необязательная конфигурация по умолчанию, поэтому мы можем просто отредактировать ее:

yarn config set ignore-optional true

Для npm нет конфигурации по умолчанию, поэтому мы можем создать ее:

npm config set ignore-optional true

Используйте sudo npm install -g appium.

Переключиться на PNPM: https://pnpm.js.org/

Предупреждения fsevents исчезли (в Linux).

Даже последняя пряжа (2.x) показывает предупреждения.

запустить npm install -D vue-loader vue-template-compiler Vue CLI Если вы не заинтересованы в настройке веб-пакета вручную, рекомендуется вместо этого создать проект с помощью Vue CLI. Проекты, созданные с помощью Vue CLI, предварительно настроены с учетом большинства общих потребностей разработки, выполняемых из коробки.

Следуйте этому руководству, если встроенная конфигурация Vue CLI не соответствует вашим потребностям или вы предпочитаете создать свою собственную конфигурацию веб-пакета с нуля.

# Ручная настройка #Установка Если вы не являетесь опытным пользователем, использующим собственную разветвленную версию компилятора шаблонов Vue, вам следует установить vue-loader и vue-template-compiler вместе:

I solved this by deleting the node_modules folder and running npm i.

Я использую, Угловой интерфейс командной строки: 8.1.2 Узел: 12.14.1 ОС: win32 x64

Странно, мне это помогло

npm cache clean --force
npm uninstall @angular/cli
npm install @angular/cli@8.1.2

Если у кого получится эта ошибка для ionic cordova install. просто используйте этот код npm install --no-optional в вашем cmd. А затем запустите этот код npm install -g ionic@latest cordova

Сделайте так:

npm install --no-optional

Для получения дополнительной информации: https://github.com/npm/npm/issues/11632

Это больше не происходит с npm v7. Вы можете обновить свою версию npm или обновить до узла v15 или выше, который по умолчанию устанавливает npm v7.

Проверьте версию своего узла и убедитесь, что package.json был сгенерирован с использованием другой версии узла.

Я загрузил репо, созданный с Mac, из Linux и столкнулся с этой ошибкой при попытке npm install. Я использовал node v14.15.0, и когда я перешел на v16.13.0, ошибка исчезла.

Для тех, кто читал это недавно, самое простое, что можно сделать в Ubuntu, - это установить последние LTS-версии nvm, node.js и nmp. в node.js версии 7 эти проблемы устранены.

См. Это руководство: https://computingforgeeks.com/how-to-install-node-js-on-ubuntu-debian/

Если вы хотите скрыть это предупреждение, вам просто нужно установить fsevents как дополнительную зависимость. Просто выполните:

npm i fsevents@latest -f --save-optional

.. И предупреждать больше не будет.

package.json подсчитывается с ключом optionalDependencies. NPM по необязательным зависимостям.

Вы можете добавить к этому объекту fsevents, и если вы обнаружите, что устанавливаете пакеты на другой платформе, чем MacOS, fsevents будет пропущен либо yarn, либоnpm.

"optionalDependencies": {
  "fsevents": "2.1.2"
},

В журнале установки вы найдете следующее сообщение:

info fsevents@1.2.11: Платформа "linux" несовместима с этим модулем.
info «fsevents@1.2.11» - это необязательная зависимость и неудачная проверка совместимости. Исключение из установки.
info fsevents@2.1.2: Платформа "linux" несовместима с этим модулем.
info «fsevents@2.1.2» - это необязательная зависимость и неудачная проверка совместимости. Исключение из установки.

Надеюсь, это поможет!

У меня тоже была такая же проблема, хотя я использую MacOS. Проблема в какой-то ошибке. Я решил эту проблему, многократно выполнив команды

sudo npm cache clean --force 
sudo npm uninstall 
sudo npm install

Один раз это не сработало, но когда я несколько раз очищал кеш и после удаления npm, переустановки npm, ошибка исчезла. Я использую Angular 8, и это обычная проблема

Выполните следующие действия -

  1. Перейти к файлу проекта package.lock.json
  2. Нажмите «Ctrl + F» (для включения поиска)
  3. Наберите «дарвин»
  4. Переименуйте его в 'linux'

node_module_fsevents

Да, работает с командой npm install --no-optional
Используемая среда:

  • iTerm2
  • macos войдите в мою виртуальную машину ubuntu16 LTS.

2022 WebDevInsider