Мне нужно использовать старую версию React Native (0.59.10)

Когда я инициализирую новый проект вот так

npx react-native-cli init rnTestTest --version 0.59.10

и затем я запускаю тест yarn test

ошибка следующая:

Тестовый пакет не удалось запустить

    Cannot find module 'setupDevtools' from 'node_modules/react-native/jest/setup.js'

      at Resolver.resolveModule (node_modules/jest-resolve/build/index.js:306:11)
      at Object. (node_modules/react-native/jest/setup.js:3:15)

Почему возникает эта ошибка?

Ответы (1)

Я не нашел подходящего решения для этой проблемы. Я ожидал, что запуск с нуля нового шаблона react-native заставит тест работать.

Что я сделал, так это понизил версию jest. Так что теперь в devDependencies у меня есть такие версии:

 ...
    "@types/jest": "^26.0.19",
    "babel-jest": "24.9.0",
    "jest": "24.9.0",
    ...

2022 WebDevInsider